MacOS X High Sierraにアップデートすると、CocoaPodsが動かなくなる件の解決方法

急にKeynoteの最新版のアップデートができなくなった関係でOSをHigh Sierraにアップデートしたところ、今まで問題なく使えていたCocoaPodsが動かなくなりました。一つ変更が加わると次々と影響を受けるのはよくあることですが、矢継ぎ早に起こるとまあまあ腹が立ちます笑

とりあえず原因はCocoaPodsを動かすのに必要なrubyのpathが変更されたことのようです。下記のような対応を行うと復旧できます。

参考リンク
https://github.com/CocoaPods/CocoaPods/issues/6898#issuecomment-332060096

返信を残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です